ECX Amp MT - one of my rear shock keeps coming out, I can’t find a rebuild video, does anyone have a link to one?

Rockstead

Member
Messages
23
I have a feeling one of my rear shocks is missing a part, I got it to stay in place by using the e-clips and thing in between but they still pop out and always on the same side, so I’m thinking maybe it’s missing a piece.

Hopefully there is a video I can follow where it’s broken down and rebuilt.

642683A7-2392-456C-9A80-5D7A77522EBA.jpeg
 
Last edited:

X

Conspiracy of One
Staff member
Supporting Member
Messages
1,133
Post a picture of your setup. Best way for others to help you.
 

Rockstead

Member
Messages
23
Post a picture of your setup. Best way for others to help you.
I updated the original post, you can see the metal pin in the shock came out.

I was under the impression I rebuilt it correctly but maybe I’m doing something wrong for it to keep popping out.

That’s why I was looking for a build video for it.
 

X

Conspiracy of One
Staff member
Supporting Member
Messages
1,133
I updated the original post, you can see the metal pin in the shock came out.

I was under the impression I rebuilt it correctly but maybe I’m doing something wrong for it to keep popping out.

That’s why I was looking for a build video for it.


Here is an exploded view of the rear shock.

5379


I don't see anything special besides the e-clips and piston. Perhaps your shock shaft has the grooves that the e-clips sit in worn? Or maybe the e-clips are loose/ worn?

I would likely try replacing the e-clips.
 

Rockstead

Member
Messages
23
Here is an exploded view of the rear shock.

View attachment 5379


I don't see anything special besides the e-clips and piston. Perhaps your shock shaft has the grooves that the e-clips sit in worn? Or maybe the e-clips are loose/ worn?

I would likely try replacing the e-clips.
Thank you, I’m going to break mine down and post a picture.

Those e-clips are so small, is there a maintenance kit I can order that has extras of these small types of parts?

Also, where did you find this expanded picture?
 

X

Conspiracy of One
Staff member
Supporting Member
Messages
1,133
Thank you, I’m going to break mine down and post a picture.

Those e-clips are so small, is there a maintenance kit I can order that has extras of these small types of parts?

Also, where did you find this expanded picture?

You could likely find a compatible clip if you stop by your local hobby shop. Otherwise, the ECX part number is on the exploded view, ECX1057.

That exploded view is on Horizon hobby's site, HERE. It's listed under the "Manuals and Support" tab. The BTD and the standard Amp are functionally the same. Only difference is that one is RTR and the other is a kit. Not sure why they don't list the exploded view under the standard Amp.
 

Rockstead

Member
Messages
23
Horizon Hobby has a few different Shock rebuild kits, but none of them are branded ECX, does anyone know which kit is compatible with the ECX Amp?
 

Rockstead

Member
Messages
23
So a few answers, pretty annoying but Horizon Hobby doesn’t sell full stock shock kits, you have to buy everything separately to rebuild the stock shock.

I verified and my shock had all the parts and I secured everything, filled the oil (maybe too high) and I pulled hard on the hinge and the s-clips was holding it together but the metal shock pin will still come out when I get on the road, no idea what I’m doing wrong and only that shock, although ive never tried rebuilding any my others and I’ve never refilled the oil on them either but the have a nice smooth movement.

94B84E29-22C9-43A2-B7B1-B80FF548E0AD.jpeg
 

WithinU

Well-Known Member
Messages
234
Location
Land of Oz
I'm not an expert mind you.
When you say, you pulled hard and the shaft comes out. I assume it's only the shaft? If so then I would say the E clips are sprung open and not holding firm to the shaft. Are the E clips easy to snap onto the shaft? Other than being tiny and hard to hold onto.....LOL
 

Rockstead

Member
Messages
23
I'm not an expert mind you.
When you say, you pulled hard and the shaft comes out. I assume it's only the shaft? If so then I would say the E clips are sprung open and not holding firm to the shaft. Are the E clips easy to snap onto the shaft? Other than being tiny and hard to hold onto.....LOL
Well initially I thought it was the e-clips, but they feel tight and secure after I rebuild the shock and then I test the shock by trying hard to pull on it and the e-clips don’t let go, but any road usage and the e-clips must be giving out on that side and then the the metal pin comes out of the shock shaft.

No idea what I’m doing wrong or what to try next, any help would be appreciated.
 
Top