new revenge esc wont hold a 4s!!

stik

Member
Messages
7
I got a revenge because ECX is tuff against breaking, but only because they say 4s will work with ESC, just change the motor, not so anymore, they changed firmware to make it impossible to run a 4s with ESC, even if you change to the 1800 dynamite motor..kinda disappointed with this!!
 

yellowdatsun

Member
Messages
9
@stik I got one recently, and the esc *should* take 4 or 5s I believe, but the motor is only rated for 3s. Not sure why you're having issues with 4s, it should work. What I've read on the net, and on the instructions show that to be true. I will add thought, that it's stupid fast on 3s, maybe you can live with that?
 

yellowdatsun

Member
Messages
9
Curious where you got the info about the firmware. It says right on their website that the esc will handle 4s, but not the motor. Sooo, I'm guessing you got the wrong motor, got it too hot, there could be a ton of variables here. Even looking at the esc's through Losi's name they say 4s. So I've gotta believe if two different companies are telling me it's 4s, then it's gotta be 4s.

http://www.ecxrc.com/Products/Default.aspx?ProdID=ECX0800
 
Last edited:

X

Conspiracy of One
Staff member
Premium Member
Messages
1,216
It seems like it is not uncommon to have firmware limiting based on the programmed setup. My circuit's esc/motor combo shows that it is capable of 3s. And the first time I ran the truck it did. Then I reset the firmware after mistakenly inputting the wrong value. From that point on it never ran 3s again. When I spoke to ECX they stated that that particular setup was never intended to run 3s and it was a fluke that it every did.

Oh....if I could turn back time...
 

Latest posts

Members online

Top