Precautionary Thread. The Tazer BL setup does not run 3s....if it comes on a vehicle.

X

Conspiracy of One
Staff member
Premium Member
Messages
1,216
Last week I purchased the BL Circuit. On the webpage, it calls out the system as 2s capable.

upload_2016-6-1_8-15-44.png

However, when you look at the page for the ESC/ motor it states it is 2s/3s capable.

upload_2016-6-1_8-16-54.png

So, obviously I was excited that the rig could be run on 3s. Sadly this excitement was short lived. I made a very short run on 3s to verify functionality and then brought the truck in to check and update the ESC settings. Low voltage cutoff in particular. Sadly after programming, I no longer had throttle control. I reset the ESC thinking somehow I messed up with the programming, no change. I called tech support and was ran through a re-setup. After that I told them I was running a 3s. He tells me that system cannot run 3s. I point out that it did and that the page states as such. He says that the system pre-installed into vehicles come programmed as only 2s capable because drive-train stress is an issue. Also, that the unit when bought separately can run 3s because they don't know what vehicle it is going into.

After doing a bit of internet searching, which now I wish I had done before buying, it seems many people have lost 3s capability after doing ESC setup, in particular after changing the low voltage cutoff.

So.....if you are fortunate enough to have 3s functionality in your stock BL ECX vehicle, I would recommend not touching the ESC settings.

Has anyone seen a way to revert to 3s capable? I will ofcourse update this thread if I find a way.
 

WoodiE

Kind of good admin
Staff member
Messages
918
Location
Lexington, KY
What?! That's a bit crazy, the same ESC is capable of doing 3s but they limit it on certain models? While I understand why, at the very least you'd think there would be an easy way to enable it... what if you decided to take that ESC from the Circuit and place it in another RC, you still wouldn't be able to do 3s.

Seems a bit crazy and like they should be an option to enable if desired.
 

X

Conspiracy of One
Staff member
Premium Member
Messages
1,216
I agree. Sadly Dynamite is owned by horizon hobby, and they use the same tech line. Doubtful that I will get anyone to admit if something exists to set it to 3s enabled.....
 

Aunion

Well-Known Member
Messages
107
Location
Fuenlabrada, Madrid, España
Hi.
To be honest, when I started twisting driveshafts in my BL Ruckus with 2s Lipo, I decided not to try any 3s. But I would really like to try it, although I'll have to buy them first. But I can't understand how they can program the ESC not working with 3s when it's capable. I need to ask my RC fellas for a 3s Lipo to try, and if I can't drive it that way, I'm happy enough with it with 2s.
EDIT: Sorry about my English if it's not clear enough, I'm from Spain.
 

brittonjeff

New Member
Messages
1
Last week I purchased the BL Circuit. On the webpage, it calls out the system as 2s capable.

View attachment 682

However, when you look at the page for the ESC/ motor it states it is 2s/3s capable.

View attachment 683

So, obviously I was excited that the rig could be run on 3s. Sadly this excitement was short lived. I made a very short run on 3s to verify functionality and then brought the truck in to check and update the ESC settings. Low voltage cutoff in particular. Sadly after programming, I no longer had throttle control. I reset the ESC thinking somehow I messed up with the programming, no change. I called tech support and was ran through a re-setup. After that I told them I was running a 3s. He tells me that system cannot run 3s. I point out that it did and that the page states as such. He says that the system pre-installed into vehicles come programmed as only 2s capable because drive-train stress is an issue. Also, that the unit when bought separately can run 3s because they don't know what vehicle it is going into.

After doing a bit of internet searching, which now I wish I had done before buying, it seems many people have lost 3s capability after doing ESC setup, in particular after changing the low voltage cutoff.

So.....if you are fortunate enough to have 3s functionality in your stock BL ECX vehicle, I would recommend not touching the ESC settings.

Has anyone seen a way to revert to 3s capable? I will ofcourse update this thread if I find a way.
try a different 3s mine works with one but not my new 3s "gens ace"
 

Latest posts

Members online

Top