Premium members don't see ads. Clickhereto upgrade.

Replaced my servo and something doesn’t seem right..

Tama

Well-Known Member
Messages
62
Turn everything off, adjust trim on controller so it's centered, remove steering horn frm servo, put pwr bak thru so ur servo adjust itself mount steering horn and all should b fine, if not, adjust trim.
Feel free 4 any1 2 correct me if im wrng🤔
 

Steve g

Well-Known Member
Messages
220
Location
Massachusetts
That looks like a cheapo 20kg Chinese servo right? I have 2 in mine, and what it was is the splines dont line up perfect with the trim at zero. So the front wheels point more in one direction, and turn more in that direction, until you get your wheels straight using the steering trim. Even then it wasn't perfect. There is a way to adjust the endpoints on it, and even the servo center depending on your radio. But first make sure its on as centered as you can het it as the previous posts mention.
 

Tama

Well-Known Member
Messages
62
Hit and miss with them servos, i brought 3 of em 20kg 1's off Wish☺ my bad, but hav only had 1 die on me within 5mnths. Other 2 been goin well for the past 2yrs no issues...
 

Heyitsme

Well-Known Member
Messages
288
Nothing wrong you can't turn any more on that one side because the servo horn looks like it hits the side of the chassis. It mechanically can't go anymore on that one side because it hits there's nothing on the other side to stop the servo from turning like there is on the side where the servo horn hits. That's why it turns more on one side more than the other IMHO. Turn your steering D/R knob down till the one side that hits no longer hits this should equal out your steering left and right as long as your servo horn was centered on the servo right when you installed it.
 

ts2340

Member
Messages
6
Ok finally worked on it. Check out my issues.

The horn hits the side.. this is without it attached to the car so may be normal.

However, I just noticed that the arm actually hits the front of the new servo...

And... the horn will now line up straight. It’s a hair to the left or a hair to the right.

Lastly, any ideas on why my one wheel does this?

Thanks!


 

Heyitsme

Well-Known Member
Messages
288
Ok finally worked on it. Check out my issues.

The horn hits the side.. this is without it attached to the car so may be normal.

However, I just noticed that the arm actually hits the front of the new servo...

And... the horn will now line up straight. It’s a hair to the left or a hair to the right.

Lastly, any ideas on why my one wheel does this?

Thanks!


Read my post #6 steering D/R
 

ts2340

Member
Messages
6
Will this servo even work bring it rubs when it moves? See the one video in the link.
Also when you say the D/R do you mean the trim on the remote?

thanks for the help.
 

Heyitsme

Well-Known Member
Messages
288
Your servo is too tall so it rubs the steering bellcrank arm. If you stood the stock servo up besides your new one you will see what I mean. Some have used that servo but had to do mods to make them fit like shave some of the top of the servo off till it doesn't rub anymore. And yes there is a steering D/R knob on your transmitter turn that knob down to where the servo horn no longer hits the side of the chassis when you turn the steering wheel. I would also get a thinner aluminum servo horn horn like this https://www.ebay.com/itm/Titanium-25T-Aluminum-Steering-Servo-Horn-Rrm-for-RC1-8-1-10-Model-Car-RSRS-US/254369385090?hash=item3b3998ca82:m:mH1F3krzp9ABsNFl5a0KXWA

 

Ecx_frills

Active Member
Messages
25
I put that servo in my car and had the same issue. The servo horn was too tall, so I had to Dremel off a bunch of the top. And then it was hitting the arm, I had to shave off part of the top of the servo as well as shave part of the arm off. It sucked and I wish I had gotten a more approved servo, but in the end I figure if I break something I'll replace it with better steering parts.
 

ts2340

Member
Messages
6
Does anyone know the exact tool size for the screws that attach the arm to the servo? The servo arm keeps popping off during bashing and my allen wrenches obviously can’t get them tight enough. Thanks
 
Top